Not signed in (Sign In)

Start a new discussion

Not signed in

Want to take part in these discussions? Sign in if you have an account, or apply for one below

  • Sign in using OpenID

Discussion Tag Cloud

Vanilla 1.1.10 is a product of Lussumo. More Information: Documentation, Community Support.

Welcome to nForum
If you want to take part in these discussions either sign in now (if you have an account), apply for one now (if you don't).
    • CommentRowNumber1.
    • CommentAuthorMike Shulman
    • CommentTimeAug 29th 2011

    Some time ago, the “Preview Post” button at the nForum has mostly stopped working for me. Usually, at least, it displays the space for my new comment above the edit-box with “Preview” background as usual, but the previewed text of my comment never appears there.

    This isn’t a big deal, since I can just use the Instiki philosophy that “save is preview” and then edit the post if I made a mistake, but I just thought I’d mention it in case it’s easy to fix. Does it still work for other people?

    • CommentRowNumber2.
    • CommentAuthorTobyBartels
    • CommentTimeAug 29th 2011

    For me, preview works better if there’s no or little math in the post. (For example, preview works just fine on this post.)

    • CommentRowNumber3.
    • CommentAuthorTom Leinster
    • CommentTimeAug 30th 2011
    • (edited Aug 30th 2011)

    I've experienced this too. I don't know what triggers it, but I had the vague impression that it was either math or formatting commands (links etc). When it doesn't work, what I see instead of a preview is an empty box about one or two lines high.

    • CommentRowNumber4.
    • CommentAuthorRodMcGuire
    • CommentTimeAug 30th 2011
    • (edited Aug 30th 2011)

    What may be causing it is that the nForum doesn’t know how to handle iTeX. Instead it bundles it up and sends it as a request to (I think the nLab or some Instiki) which does the translation and sends it back. If this “math server” is having problems, then that may be the cause of nForum problems.

    If the cause is sending things to the nLab then it might make sense to set up a separate math server for the nForum.

    • CommentRowNumber5.
    • CommentAuthorTobyBartels
    • CommentTimeAug 30th 2011

    Yes, I remember Andrew saying that the Forum’s itex is done by the Lab.

    However, I doubt that this is the whole issue. Even when the preview doesn’t show up, the comment still appears on submission, math and all.

    • CommentRowNumber6.
    • CommentAuthorAndrew Stacey
    • CommentTimeAug 30th 2011

    I noticed this yesterday when doing a post on another forum here. It’s from when I updated the nLab over the summer (so I’m a little surprised no-one mentioned it before now!). Basically, I made a mistake when reinstalling the iTeX stand-alone converter on the nLab machine. I have a modified version of iTeX that outputs numbered entities instead of named entities. When the page is rendered, that doesn’t matter, but when the snippet is rendered for the preview then (for some reason I don’t fully understand) it does matter. So I need to reinstall the iTeX stand-alone server on the nLab to use my modified version.

    Sorry!

    • CommentRowNumber7.
    • CommentAuthorzskoda
    • CommentTimeAug 30th 2011

    For me, the preview does not appear at start, but after a long while it does. At least that is how it was yesterday.

    • CommentRowNumber8.
    • CommentAuthorMike Shulman
    • CommentTimeSep 11th 2011

    I just had this happen to me with a comment containing exactly one mathematical symbol. So it isn’t just “having a lot of math” which makes it happen. Removing that one symbol, though, or changing the formatting to plain “Markdown”, did fix the problem.

    • CommentRowNumber9.
    • CommentAuthorAndrew Stacey
    • CommentTimeSep 11th 2011

    A single entity causes the problem.

    When I get a minute, I’ll fix this. But there’s a quick fix and a proper fix, which will not only fix the preview but also (I hope) make it faster. So I’d like to do the proper fix.

    • CommentRowNumber10.
    • CommentAuthorRodMcGuire
    • CommentTimeSep 18th 2011

    Any guess on when this will be fixed?

    • CommentRowNumber11.
    • CommentAuthorAndrew Stacey
    • CommentTimeSep 18th 2011

    Let’s try the preview: α+β+γ\alpha + \beta + \gamma. On the off-chance that that was already in the cache, let’s try something more bizarre: αβ+γδ+ α βdγ=μ+λ*ζ+ \alpha \beta + \sum \gamma \delta + \int_{\alpha}^{\beta} d \gamma = \mu + \lambda * \zeta + \prod_{\mathbb{N}}.

    So long as neither of those were in the cache, the preview should now be working.

    (My apologies for being lazy. Once I actually looked at it, I just needed to add three letters in a configuration option on the forum.)

    Please let me know if this didn’t fix it, or if it broke something else in the meantime.

    • CommentRowNumber12.
    • CommentAuthorRodMcGuire
    • CommentTimeSep 18th 2011
    • (edited Sep 18th 2011)

    It works me forworks_{me}^{for}. I’ll watch out for anything else being broken.

    Thanks a merciful bucket load.

Add your comments
  • Please log in or leave your comment as a "guest post". If commenting as a "guest", please include your name in the message as a courtesy. Note: only certain categories allow guest posts.
  • To produce a hyperlink to an nLab entry, simply put double square brackets around its name, e.g. [[category]]. To use (La)TeX mathematics in your post, make sure Markdown+Itex is selected below and put your mathematics between dollar signs as usual. Only a subset of the usual TeX math commands are accepted: see here for a list.

  • (Help)