Not signed in (Sign In)

Start a new discussion

Not signed in

Want to take part in these discussions? Sign in if you have an account, or apply for one below

  • Sign in using OpenID

Site Tag Cloud

2-categories 2-category 2-category-theory abelian-categories adjoint algebra algebraic algebraic-geometry algebraic-topology analysis analytic-geometry arithmetic arithmetic-geometry bundles calculus categorical categories category category-theory chern-weil-theory cohesion cohesive-homotopy-type-theory cohomology colimits combinatorics complex-geometry computable-mathematics computer-science constructive cosmology deformation-theory descent diagrams differential differential-cohomology differential-equations differential-geometry differential-topology digraphs duality elliptic-cohomology enriched fibration finite foundations functional-analysis functor galois-theory gauge-theory gebra geometric-quantization geometry graph graphs gravity grothendieck group group-theory harmonic-analysis higher higher-algebra higher-category-theory higher-differential-geometry higher-geometry higher-lie-theory higher-topos-theory homological homological-algebra homotopy homotopy-theory homotopy-type-theory index-theory integration integration-theory k-theory lie-theory limit limits linear linear-algebra locale localization logic manifolds mathematics measure-theory modal modal-logic model model-category-theory monads monoidal monoidal-category-theory morphism motives motivic-cohomology natural nlab noncommutative noncommutative-geometry number-theory of operads operator operator-algebra order-theory pages pasting philosophy physics pro-object probability probability-theory quantization quantum quantum-field quantum-field-theory quantum-mechanics quantum-physics quantum-theory question representation representation-theory riemannian-geometry scheme schemes set set-theory sheaf simplicial space spin-geometry stable-homotopy-theory string string-theory subobject superalgebra supergeometry svg symplectic-geometry synthetic-differential-geometry terminology theory topology topos topos-theory type type-theory universal variational-calculus

Vanilla 1.1.10 is a product of Lussumo. More Information: Documentation, Community Support.

Welcome to nForum
If you want to take part in these discussions either sign in now (if you have an account), apply for one now (if you don't).
    • CommentRowNumber1.
    • CommentAuthorTodd_Trimble
    • CommentTimeJun 9th 2014

    I was asked by the software to report an Apache application error, apparently triggered by attempting to click on graviton from the Authors page (at Sanath Devalapurkar).

    • CommentRowNumber2.
    • CommentAuthorUrs
    • CommentTimeJun 10th 2014
    • (edited Jun 10th 2014)

    That seems to be the remaining remnant of the cookie-induced errors that we had after the last update until something was apparently fixed. David and I had elsewhere reoported that these error messages still appear in isolation every now and then. But just reloading makes them go away.

    (To me there is no recognizable regularity in how these messages appear.)

    • CommentRowNumber3.
    • CommentAuthorRodMcGuire
    • CommentTimeJul 20th 2014

    Right now I am getting a persistent error on http://ncatlab.org/nlab/show/Langlands%20correspondence. (I’ve gotten this message in the past but it disappears on reload). The 500 error says

    Application error (Apache)

    Please report this on the nForum (in the Technical category), giving as precise details as you can as to what triggered the error.

    • CommentRowNumber4.
    • CommentAuthorUrs
    • CommentTimeJul 20th 2014
    • (edited Jul 20th 2014)

    Does it persit still? For me the page opens.

    If it persists for you, then maybe the cookie-bug is back in its strong form. Your individual workaround might be to delete your cookies then. As for an actual fix of the problem, we can only cross our fingers. Better, if you have any expertise, you might contact Adeel Khan and check if he can do with help with migrating the nLab to another platform.

    • CommentRowNumber5.
    • CommentAuthorRodMcGuire
    • CommentTimeJul 20th 2014

    delete your cookies

    It still persisted. Then in my FireFox I went in and deleted the cookie ncatlab.org: instiki_session and a reload now works.

    BTW, the content of that cookie was 4074 characters long which seems really huge for a cookie. Does anybody want to see those characters?

    • CommentRowNumber6.
    • CommentAuthorAndrew Stacey
    • CommentTimeJul 20th 2014

    The latest instiki update fixes the cookie issue hopefully once and for all so this ought to go away once that has been put in place (no longer my responsibility).

    • CommentRowNumber7.
    • CommentAuthoradeelkh
    • CommentTimeJul 21st 2014

    I’ve upgraded Instiki, so hopefully as Andrew says the cookie issue is gone now.

    • CommentRowNumber8.
    • CommentAuthorUrs
    • CommentTimeJul 21st 2014

    Thanks!!

    • CommentRowNumber9.
    • CommentAuthorkgalias
    • CommentTimeJan 13th 2015
    I keep on getting this issue, especially when I try to connect from my university network.

    I managed to resolve it somehow the last time it happened (by removing cookies and refreshing). This time it hasn't helped.
    • CommentRowNumber10.
    • CommentAuthorgtall
    • CommentTimeJan 28th 2015
    I cannot access the nlab's main page.The specific error message "Application error (Apache)" and the IP addresses I'm coming in on are in 132.250.x.x., and most likely either 132.250.22.8 or 132.250.196.100 depending on whether the connection is proxied.

    I'm at the Naval Research Lab and those are certainly not my machine addresses, so it is possible something upstream from me is putting naughty html in the transmission. This started happening around early to mid january. I've not changed anything on this end. I have no troubles from home and one of our network gurus tried from a machine outside our firewalls and had no troubles there.

    I don't have the cookies mentioned earlier and I get the same behavior from two different browsers on my mac and another on a linux machine. The network guru also tried from inside our firewall and he couldn't get in either. I hate to ask for it but is there an easy check for the logs to see what the issue is?
    • CommentRowNumber11.
    • CommentAuthoradeelkh
    • CommentTimeJan 28th 2015

    I do see 132.250.22.5 in the logs. Do you get the same error when accessing ncatlab.org:8080?

    • CommentRowNumber12.
    • CommentAuthorUrs
    • CommentTimeJan 28th 2015

    I am just trying again with a Telekom HotSpot connection from a German ICE and that gives what seems to be the same kind of problem: every page of the nLab gives the “Application error (Apache)”. Using ncatlab.org:8080 gives “Bad Gateway”.

    • CommentRowNumber13.
    • CommentAuthorRodMcGuire
    • CommentTimeJan 28th 2015
    • (edited Jan 28th 2015)

    I don’t have the cookies mentioned earlier

    Is it possible the Naval Research Lab is blocking or managing cookies for security or privacy reasons?

    adeelkh: Does the nLab require that a cookie be settable and be set in order to interact with a user?

    I just checked and my FireFox does have the cookie ncatlab.org: instiki_session which is Expires: At end of session, which I presume means when I have closed my last open window to the nLab.

    EDIT: I just went into a different FireFox profile and under Tools > options > Privacy I selected Use custom settings for history where I unchecked Accept cookies from sites and I still seem to be able to access the nLab with no cookies.

    So unless the NRL is somehow managing cookies this may not be a cookie problem.

    • CommentRowNumber14.
    • CommentAuthoradeelkh
    • CommentTimeJan 28th 2015

    I don’t think it’s a cookie problem. I think it’s the same issue Urs had. I was unable to find anything relevant in the logs, which means I’ll have to trace the problem to its source in the software. I’ll try to look into it tomorrow if I get some time. Sorry about this.

    • CommentRowNumber15.
    • CommentAuthorgtall
    • CommentTimeJan 29th 2015
    Our network guru seems to have a line on the problem. I'll repeat his mail to me here:
    -----------------------------
    After a little more testing, it appears that the "X-Forwarded-For:" tag that the proxy puts into the HTTP connection is what Apache is choking on.
    I verified this by connecting manually with "telnet www.ncatlab.org 80" from the working network connection.
    If I just give it the commands "GET /nlab/show/HomePage HTTP/1.1" and "host: ncatlab.org", it works. If I tack on "X-Forwarded-For: 8.8.8.8", it bombs with the Application error.
    Just to be really specific, I tried tacking on a bogus "X-Tuna-Fish: 8.8.8.8" header, and that worked fine -- it's X-Forwarded-For that crashes it.
    • CommentRowNumber16.
    • CommentAuthoradeelkh
    • CommentTimeJan 29th 2015

    Ah, that is very helpful, thanks!

    • CommentRowNumber17.
    • CommentAuthoradeelkh
    • CommentTimeJan 29th 2015

    I think the issue should be resolved now. Can you confirm?

    • CommentRowNumber18.
    • CommentAuthorgtall
    • CommentTimeJan 29th 2015
    Yep, thanks!! I can now get to nLab.
    • CommentRowNumber19.
    • CommentAuthoradeelkh
    • CommentTimeJan 29th 2015

    Great! Thanks to you and your network guru for help with resolving this.

    • CommentRowNumber20.
    • CommentAuthorMike Shulman
    • CommentTimeJan 29th 2015

    I am curious, what was causing Apache to choke on “X-Forwarded-For”?

    • CommentRowNumber21.
    • CommentAuthoradeelkh
    • CommentTimeFeb 2nd 2015

    I’m sure I wrote a reply here earlier, but it seems it didn’t go through.

    The error in fact didn’t have anything to do with Apache (the error message was a lie). It was caused rather by a bug in the old version of Ruby on Rails that Instiki is built on.

Add your comments
  • Please log in or leave your comment as a "guest post". If commenting as a "guest", please include your name in the message as a courtesy. Note: only certain categories allow guest posts.
  • To produce a hyperlink to an nLab entry, simply put double square brackets around its name, e.g. [[category]]. To use (La)TeX mathematics in your post, make sure Markdown+Itex is selected below and put your mathematics between dollar signs as usual. Only a subset of the usual TeX math commands are accepted: see here for a list.

  • (Help)